Now the final version has been released of Mountain Loin it seems that Apple has a better idea of what the new OS will be capable of running on, and it seems unfortunately that a few computers will get left behind after the update, their official upgrade page gives us an idea of what this will work on and includes:

  • iMac (mid-2007 or newer)
  • MacBook (late 2008 aluminum, or early 2009 or newer)
  • MacBook Pro (mid/late 2007 or newer)
  • MacBook Air (late 2008 or newer)
  • Mac mini (early 2009 or newer)
  • Mac Pro (early 2008 or newer)
  • Xserve (early 2009)

Were not sure why the older devices will not be supported, but as a lot of the machines are older than 3 years it doesn’t seem to bad of Apple if I’m honest and it’s probably time to get a new one anyway.

This article may include links to affilates, and if you click on one of these affilate links, we may recieve commission.